OptiPerl does everything possible to emulate a real production environment for running scripts. However it can not emulate a real production server! You might need sometimes, after uploading to a server, to do additional fine-tuning, debugging and running on the production server it self. OptiPerl helps here also; you can open a remote file via one of the remote transfer sessions, edit it, upload it automatically and run in on the server.

 

icon_idea See also some common reasons why you might get 500 errors after uploading.

 

When running, the actual request that it's users would use is sent. If the script gets accessed by http://www.mysite.com/cgi-bin/test.cgi, that's what optiperl will use, by sending the request in it's browser so you can view the result.

 

However all of OptiPerl's tools are at your disposal for sending the request. You can fine tune the query from the query editor if you want, so you can discover potential holes. Or enable the Spy proxy to view the exact request and response from the production server.

 

To edit remote files, you must setup an remote transfer session so you can open the files. To run them by sending requests to the server, you must also fill the fields of the remote session dialog that help link absolute paths of the FTP or SFTP server to HTTP requests. Read about possible scenarios to do this.

 

To open/edit/run/save a remote file do the following:

 

1) Select menu File / Open remote file

2) Select a session, press the connect button and select the remote file

3) It will be downloaded and opened in OptiPerl

4) Edit it. To run it, have "Servers / Run with server" enabled, and press Run. If the file had been changed, it will be uploaded automatically.

5) To debug it, add a -d parameter in the shebang, select "Debug / Listen for remote debugger" and press run. Make sure the PERLDB_OPTS is set in the remote machine's environment. Read more about remote debugging.

6) To save it, select menu File / Save remote file.

7) To save it on a different remote session, select menu File / Save remote file as. In the dialog select the session and a filename if needed and press save.

 

icon_idea If enabled for the transfer session (change shebang and convert version) then the shebang will be changed when uploading a script to what the remote server needs. Also when uploading, the version can be converted to SERVER and when downloading to LOCAL.

 

Top  Previous  Next